请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

顶牛网官方QQ交流群

股票配资1-10杠杆

公布一只涨停5%

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 171|回复: 1

[通达信] 通达信擒龙黑马指标公式(源码 副图 主图 贴图)

[复制链接]

7059

主题

13

听众

4万

积分

顶牛元老

Rank: 8Rank: 8

UID
507
好友
7
精华
1
顶牛币
19503
在线时间
441 小时
注册时间
2012-10-24
发表于 2018-2-14 08:46 |显示全部楼层
分享到:
J5:MA(CLOSE,5);
J10:MA(CLOSE,10);
J20:MA(CLOSE,20),LINETHICK2;
IF(J20>REF(J20,1),J20,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(J20<REF(J20,1),J20,DRAWNULL),COLORCYAN,LINETHICK2;
J60:MA(CLOSE,60),COLORGREEN;
J120:MA(CLOSE,120),COLORLIGRAY;
J250:MA(CLOSE,250),COLORBLUE;
涨停:=IF(REF(C,1)*1.1-C<0.01,1,0);
GGD:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,20);
G1:=GGD/REF(GGD,1)>=1.6;
G2:=(V/REF(V,1)>=1.90 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND V/REF(V,1)>=1.90);
STICKLINE(G1 AND G2,O,C,1,0),COLORWHITE;
BL:=C>O AND C>REF(C,1);
SBL:=REF(VOL,1)/VOL>1.9;
XGRR:=REF(BL,2) AND REF(C<O,1) AND SBL;
STICKLINE(XGRR,OPEN,CLOSE,4,0),COLORYELLOW;
STICKLINE(XGRR,C,O,3,0),COLORLIMAGENTA;
XING:=6/1000;
XXTJ:=ABS(C-O)/C<XING AND H>MAX(C,O) AND L<MIN(C,O);
YS:=COUNT(REF(XXTJ,1),2)>=1 AND V>REF(V,1)*1.9 AND C>REF(C,1);
BLSJQ:=NOT(REF(YS,1)) AND YS AND C>MA(C,20) AND C>MA(C,60) AND ( C>MA(C,120) OR  C>MA(C,250));
STICKLINE(BLSJQ,C,(C+O)/2,1.5,0),COLORRED;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DK:=O>REF(H,1) AND C>REF(H,1) AND L>REF(H,1);
ZTQ:=C<REF(C,1)*1.07 AND NOT(REF(C>REF(C,1)*1.09 AND C=H,1));
SYX:=(H-MAX(C,O))/MAX(C,O)*100>3.7 AND H>HHV(REF(H,1),20);
换手:=VOL/CAPITAL*100;
T5:=换手>2 AND 换手<35;
跳空上阴:=(DK OR SYX) AND ZTQ AND C<45 AND T5;
DRAWTEXT(跳空上阴 AND C>MA(C,21),H+0.09,'异');
LL:=REF(L,2);
XQK:=REF(H,1)<LL;
YSB:=REF(C,1)<REF(O,1) AND REF(VOL,1)/VOL>1.90;
STICKLINE(XQK AND YSB,H,L,0.1,0),COLORLICYAN;
DRAWTEXT(XQK AND YSB,L-0.1,'洗盘底');
跌幅:=-(C-REF(C,1))/REF(C,1)*100;
GY2:=O<REF(L,1) AND REF(C<O,1) AND BETWEEN(C/O,0.99,1.02) AND C<REF(C,1) AND (跌幅>2.5 OR (C>REF(C,1) AND C<O));
弃婴:=(O<REF(L,1) AND REF(C<O,1) AND BETWEEN(C/O,0.99,1.02) AND C<REF(C,1) AND ABS(OPEN-CLOSE)/CLOSE<0.04 AND CLOSE<MA(CLOSE,5)) OR (O<REF(L,1) AND REF(C<O,1) AND BETWEEN(C/O,0.99,1.02) AND C<REF(C,1));
STICKLINE((弃婴 OR GY2) AND C<MA(C,5),H,L,0.1,0),COLORYELLOW;
STICKLINE((弃婴 OR GY2)  AND C<MA(C,5),O,C,2,0),COLORMAGENTA;
倍量:=(V/REF(V,1)>=1.90 AND COUNT(C>O,1)) OR (L>REF(H,1) AND COUNT(O>C,1) AND V/REF(V,1)>=1.90);
STICKLINE(倍量,C,(C+O)/2,1,0),COLORYELLOW;
★早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
★黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND
CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
★长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
★垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH;
★早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
★黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
★倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >2.5*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
STICKLINE(★倒转锤头,O,C,1,0),COLORMAGENTA;
STICKLINE(★倒转锤头,H,L,0,0),COLORMAGENTA;
★锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
STICKLINE(★锤头,O,C,3,0),COLORMAGENTA;
STICKLINE(★锤头,H,L,0,0),COLORMAGENTA;
★吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
★穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
★乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
★曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
STICKLINE(★曙光初现 OR ★早晨之星,O,C,2,0),COLORMAGENTA;
★身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
★十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
★平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
★平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001);
★大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
★红三兵:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
★双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
★孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100  AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
★多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
★出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
★上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
★下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
★跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
★三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
★光脚阴线:=LOW=CLOSE AND HIGH!=LOW;
★光头阳线:=HIGH=CLOSE AND HIGH!=LOW;
★分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;

7059

主题

13

听众

4万

积分

顶牛元老

Rank: 8Rank: 8

UID
507
好友
7
精华
1
顶牛币
19503
在线时间
441 小时
注册时间
2012-10-24
发表于 2018-2-14 08:46 |显示全部楼层
★长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
★长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
★十字星:=CLOSE=OPEN AND HIGH!=LOW;
★大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
★好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
★倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
DRAWTEXT( ★早晨之星,IF(★早晨之星,H,L-L*0.001),IF(★黄昏之星,IF(★十字星,'',''),IF(★十字星,'',''))),COLORGREEN;
DRAWTEXT(★乌云盖顶 OR ★曙光初现 OR ★好友反攻,IF(★乌云盖顶,H,L-L*0.001),IF(★乌云盖顶,'',IF(★曙光初现,'曙',''))),COLORLIGRAY;
DRAWTEXT(★锤头 OR ★倒转锤头 OR ★孕育线,IF(★锤头,H,L-L*0.001),IF(★锤头,'',IF(★倒转锤头,'',''))),COLORLIGREEN;
DRAWTEXT(★平顶 OR ★平底,IF(★平顶,H,L),IF(★平底,'','')),COLORLICYAN;
GL1:=(MA(C,20)-MA(C,250))/MA(C,250)*100<0.5;
GL2:=(MA(C,20)-MA(C,30))/MA(C,30)*100<3;
GL3:=(MA(C,20)-MA(C,60))/MA(C,60)*100<4;
NEWTJ1:=MA(C,5)>=MA(C,10) AND  (MA(C,10)>=MA(C,20) OR CROSS(MA(C,10),MA(C,20))) AND (MA(C,20)>=MA(C,30) OR GL2) AND MA(C,10)>MA(C,60) AND MA(C,10)>=MA(C,250) AND (MA(C,20)>=MA(C,250) OR GL1);
NEWTJ2:=MA(C,5)>=MA(C,10) AND  (MA(C,10)>=MA(C,30) OR CROSS(MA(C,10),MA(C,20))) AND (MA(C,20)>=MA(C,30) OR GL2) AND MA(C,10)>=MA(C,60) AND GL3;
V5:=MA(VOL,5);
V10:=MA(VOL,13);
V35:=MA(VOL,35);
V60:=MA(VOL,60);
M5:=MA(CLOSE,5);
M10:=MA(CLOSE,10);   
M20:=MA(CLOSE,20);
M60:=MA(CLOSE,60);
M120:=MA(CLOSE,120);
TJ1:=REF(V,1)<REF(V5,1) AND REF(V,1)<REF(V10,1) AND REF(V,1)<REF(V60,1) AND (V5>=V10 OR V5>=V60 OR V5>=V35);
TJ2:=V5>V35 AND V10>=V60 AND V10>=V35;
TJ3:=V5>=V10 AND V5>V60 AND (V10>=V60 OR V10>=V35);
LTP:=C<40 AND FINANCE(7)/100000000<14  AND IF(NAMELIKE('*'),0,1)  AND  IF(NAMELIKE('S'),0,1);
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,13);
MA3:=MA(CLOSE,21);
AQ:=MAX(MAX(MA1,MA2),MA3);
B:=MIN(MIN(MA1,MA2),MA3);
DSXN:=RANGE(100*(AQ-B)/B,0,5),100*(AQ-B)/B<12;
M6:=MA(CLOSE,60);
M7:=MA(CLOSE,89);
M8:=MA(CLOSE,120);
LD:=MAX(MAX(M6,M7),M8);
LX:=MIN(MIN(M6,M7),M8);
JXZQ:=RANGE(100*(LD-LX)/LX,0,5),100*(LD-LX)/LX<15;
JGTJ:=REF(C,1)/REF(C,2)<1.09 AND C/REF(C,1)>=1.01;
ZT:=C>REF(C,1)*1.09 AND C=H;
ZTTJ:=COUNT(REF(ZT,3),179)>0;
G8:=MA(C,8);
G13:=MA(C,13);
G89:=MA(C,89);
JXGTJ:=M5>M60 AND M5>G89 AND M5>M120 AND G13>M60 AND G13>G89 AND G13>M120 AND G8>M60 AND G8>G89 AND G8>M120;
JGTJ1:=REF(C,1)/REF(C,2)<1.08 AND C/REF(C,1)>=1.01 AND REF(C,1)>REF(MA(C,250),1) AND C>REF(MA(C,120),1) AND  C>MA(C,250) AND C>MA(C,120);
GX:=(MA(C,21)-M60)/M60*100<8.5;
MA10:=MA(CLOSE,10);
MA54:=MA(CLOSE,54);
PL1:=(((CLOSE - MA54) / MA54) < 0.1);
PL2:=(((CLOSE - MA10) / MA10) < 0.3);
PP:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);
TY:=((((PP = 0) AND (REF(PP,1) = 0.2)) AND (REF((COUNT((PP = 0.2),10) = 10),1) = 1)) * 1);
GDXG:=TY AND (TJ1 OR TJ2 OR TJ3) AND DSXN AND ZTTJ AND JXZQ AND GX AND JGTJ;
NGO1:=GDXG AND NEWTJ1  AND JXGTJ AND JGTJ1;
NGO2:=GDXG AND NEWTJ2;
NGIN:=COUNT(NGO2,6)>0 AND CROSS(C,MA(C,250));
GJTJA:=C>MA(C,5) AND C>MA(C,250) AND C>MA(C,10) AND C>MA(C,20) AND C>MA(C,60) AND C>MA(C,30) AND C>MA(C,120) AND C>REF(C,1);
GO:=FILTER((NGO1 OR NGIN) AND GJTJA AND LTP,5);
STICKLINE(CLOSE,REF(L,BARSLAST(GO)),REF(L,BARSLAST(GO)),2,0),COLORLIMAGENTA;
DRAWTEXT(GO,L*0.99,'★'),COLORF00FF0;
A1Q:=REF(L,BARSLAST(GO));
A2Q:=REF(IF(C>O,O,(C+O)/2),BARSLAST(GO));
TSA:=BARSLAST(GO);
SJ:=BETWEEN(TSA,5,80);
NST:=IF(NAMELIKE('*'),0,1)  AND  IF(NAMELIKE('S'),0,1);
TB:=CROSS(C,A2Q);
TB2:=CROSS(C,A1Q);
GO1:=FILTER((TB OR TB2) AND C>O  AND LTP AND SJ AND C>MA(C,5) AND C>MA(C,20),8);
DRAWICON(GO1,L*0.99,11);
ZTTJS:=COUNT(REF(ZT,2),15)>0;
GG:=VAR19=1 AND C>=MA(C,20) AND MA(C,5)>MA(C,20) AND C>MA(C,10) AND ZTTJS;
XG:=GG AND DYNAINFO(9)>0 AND LTP AND JXZQ AND C>O;
DRAWICON(XG,L*0.98,13);
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
ZTS:=C>REF(C,1)*1.09 AND C=H;
TS:= BARSLAST(ZTS);
SJTJ:= BETWEEN(TS,2,5);
A5:= V<REF(V,1);
HCZC:=L<=支撑线 AND C>=支撑线;
XGG:=SJTJ AND HCZC;
DRAWICON(FILTER(XGG,3),L*0.97,11);
JA5:=MA(CLOSE,5);
JA10:=MA(CLOSE,8);
JA20:=MA(CLOSE,13);
JA30:=MA(CLOSE,21);
A1:=JA5>=JA10 AND JA10>JA20 AND JA20>JA30 AND EVERY(JA5>JA20 AND JA10>JA20 AND JA20>JA30,3);
A2:=((JA5-JA10)/JA5)*100<6 AND ((JA10-JA20)/JA10)*100<7 AND ((JA20-JA30)/JA20)*100<10;
GT1:=(MA(C,50)-MA(C,10))/MA(C,10)*100<3;
GT2:=(MA(C,10)-MA(C,20))/MA(C,20)*100<5;
GT3:=(MA(C,50)-MA(C,20))/MA(C,20)*100<7;
A3:=A1 AND A2 AND GT2 AND GT3 AND GT1 AND C>REF(C,1);
VBL:=IF(CURRBARSCOUNT=1,V*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(C>REF(C,1) AND C<O AND O/REF(C,1)>1.02 AND C>REF(C,1),O,C,1.5,0),LINETHICK2,COLORLIRED;
DRAWICON( DSXN AND ZTTJ AND JXZQ AND FILTER(NOT(REF(涨停,1)) AND A3 AND (VBL>1.9 OR V/REF(V,1)>=1.90),11),L*0.98,1);
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.01,0,0,HYBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,GNBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.3,01,0,DYBLOCK);
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册



回顶部