请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

成交量选股法

季均线出大黑马

凹口抓涨停

分时图抓涨停方法

学习和认知分时钓鱼波

抓住当日主力上涨的个股

阴线买股之老太太战法探讨

K线战法之倒拔杨柳

回调买入法初探

抓大牛股主升浪的技巧

分时强买点之:回头上穿浪

布林线的用法教程

主升浪路线图

提高抓涨停板股票的成功率

发现大牛股的唯一方法

月线形态3浪抓牛股

分时量波和量柱的涨停密码峰顶线涨停体会--漳州发展涨停透过分时图选龙头股的三种情况

量价招式擒获飞天妖股

查看: 112|回复: 1

[通达信] 通达信主力趋势指标公式、副图、贴图、源码

[复制链接]

3893

主题

9

听众

3万

积分

顶牛元老

Rank: 8Rank: 8

UID
507
好友
7
精华
1
顶牛币
16053
在线时间
204 小时
注册时间
2012-10-24
发表于 2018-2-14 08:47 |显示全部楼层
分享到:
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
趋势: IF(VAR6>45,VAR6-45,0);
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),5,0),COLORFF00FF;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),5,0),COLOR00FF00;
强弱分界:50,POINTDOT,COLORFFFFCC;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
B7:IF(B6>60,B6-60,0);
价位线:=EMA((C-V1)/(V2-V1)*4,4);
DRAWTEXT(B7>REF(B7,1) AND REF(B7,1)<=REF(B7,2) AND B7<=40,B7+5,'★'),COLORRED,LINETHICK2;
DRAWICON(B7>REF(B7,1) AND REF(B7,1)<=REF(B7,2) AND B7<=40,40,5);
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,6,1),COLORYELLOW;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
卖临界:STICKLINE(走势-AA6>85,103,100,15,1),COLOR0000FF,LINETHICK2;
I:=MA(BARSLAST(HIGH=HHV(HIGH,16))*IF(CLOSE<OPEN,VOL,1),3);
R:=MA(BARSLAST(LOW=LLV(LOW,18))*IF(CLOSE>OPEN,VOL,1),4);
短线逃顶:=IF(I,0,1),COLORGREEN;
MD1:=短线逃顶 AND C/REF(C,1)<1.09 AND L>MA(C,60) AND C>MA(C,60) AND C>MA(C,5) AND L>MA(C,5) AND H>HHV(REF(H,2),20);

A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
AAD:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;
长期线:=A+100;
短期线:=B+100,COLORWHITE,LINETHICK1;
中期线:=AAD+100,COLORYELLOW,LINETHICK2;
见顶:=(REF(中期线,1)>85 AND  REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线) ;
顶部区域:=(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5 AND 短期线<中期线 AND 短期线<长期线+4;
顶部:=FILTER(顶部区域,4);
底部区域:=(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1))) OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ;
RSV1A:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV2A:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
短线:=SMA(SMA(RSV1A,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00;
中线:=SMA(RSV2A,5,1)+2*STD(CLOSE,37),COLORRED;
RSV3A:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
长线:=SMA(RSV3A,5,1),COLORYELLOW;
看底:=STICKLINE(中线<15,中线,15,6,0),COLORF00FF0;
中线2:=-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40));
N:=12;M:=12;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
VAR1M:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2M:=SMA(VAR1M,3,1);
VAR3M:=SMA(VAR2M,3,1);
贵:=N;
VAR4M:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR5M:=CROSS(VAR4M,10) AND VAR3M<N;
M5:=MA(C,5);
M10:=MA(C,60);
JX2:=MA(C,5)<MA(C,60) AND MA(C,5)<MA(C,20) AND MA(C,10)<MA(C,60) AND MA(C,20)<MA(C,60);
离差比:=(M10-M5)/M10*100>12 AND COUNT(JX2,5)>=3;
STICKLINE(VAR5M AND 离差比,0,40,6,0 ),COLORLIMAGENTA;
DRAWICON(VAR5M AND 离差比,65,1);
DRAWTEXT(VAR5M AND 离差比,30,'抄底'),COLORYELLOW;
MDD:=短期线>90 AND C/REF(C,1)<1.09 AND L>MA(C,60) AND C>MA(C,60) AND C>MA(C,5) AND L>MA(C,5) AND H>HHV(REF(H,2),20);
DRAWICON({FILTER(MDD,5) OR} FILTER(MD1,5),100,2);
DRAWICON(顶部 AND C/REF(C,1)<1.09 AND L>MA(C,60) AND C>MA(C,60) AND C>MA(C,5) AND L>MA(C,5) AND H>HHV(REF(H,2),20),90,2);
DRAWTEXT(顶部 AND C/REF(C,1)<1.09 AND L>MA(C,60) AND C>MA(C,60) AND C>MA(C,5) AND L>MA(C,5) AND H>HHV(REF(H,2),20),85,'卖出'),COLORCYAN;
DXD:=短期线>90 AND C/REF(C,1)<1.09 AND L>MA(C,60) AND C>MA(C,60) AND C>MA(C,5) AND L>MA(C,5) AND H>HHV(REF(H,2),20);
DB:=顶部 AND C/REF(C,1)<1.09 AND L>MA(C,60) AND C>MA(C,60) AND C>MA(C,5) AND L>MA(C,5);
XPMD:=CROSS(短期线,10) AND COUNT(C>=MA(C,60),5)>3;

0

主题

0

听众

572

积分

顶牛庄家

Rank: 4

UID
90591
好友
3
精华
0
顶牛币
230
在线时间
16 小时
注册时间
2018-1-17
发表于 2018-2-16 12:08 |显示全部楼层
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册




回顶部