请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

成交量选股法

季均线出大黑马

凹口抓涨停

分时图抓涨停方法

学习和认知分时钓鱼波

抓住当日主力上涨的个股

阴线买股之老太太战法探讨

K线战法之倒拔杨柳

回调买入法初探

抓大牛股主升浪的技巧

分时强买点之:回头上穿浪

布林线的用法教程

主升浪路线图

提高抓涨停板股票的成功率

发现大牛股的唯一方法

月线形态3浪抓牛股

分时量波和量柱的涨停密码峰顶线涨停体会--漳州发展涨停透过分时图选龙头股的三种情况

量价招式擒获飞天妖股

查看: 58|回复: 0

[同花顺] 同花顺MACD&KDJ指标公式、副图、贴图、源码

[复制链接]

3893

主题

9

听众

3万

积分

顶牛元老

Rank: 8Rank: 8

UID
507
好友
7
精华
1
顶牛币
16053
在线时间
204 小时
注册时间
2012-10-24
发表于 2018-2-14 08:48 |显示全部楼层
分享到:
DRAWGBK(C>0, RGB(25,25,112),RGB(25,25,112),0,0,1);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*400-200;
K:SMA(RSV,3,1),coloryellow,NODRAW;
D:=SMA(K,3,1);
J:3*K-2*D,coloryellow,NODRAW;
DRAWBAND(J,RGB(128,0,0),K,RGB(0,0,255));
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*400-200,colormagenta,NODRAW;
RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*400-200,colormagenta,NODRAW;
DRAWBAND(RSI1,RGB(184,134,11),RSI2,RGB(70,130,180));
DI:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
DE:=EMA(DI,9);
MD:=2*(DI-DE);
STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,1.0,0),COLOR0000AB;
STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.8,0),COLOR0000BB;
STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.6,0),COLOR0000CD;
STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0,4),COLOR0000DD;
STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.2,0),COLOR0000EC;
STICKLINE(MD>0 AND MD>=REF(MD,1),0,MD,0.1,0),COLOR0000FF;
STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,1.0,0),COLOR00C3FF;
STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.8,0),COLOR00CFFF;
STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.6,0),COLOR00D8FF;
STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.4,0),COLOR00E2FF;
STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.2,0),COLOR00F0FF;
STICKLINE(MD>0 AND MD<REF(MD,1),0,MD,0.1,0),COLOR00FFFF;
STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,1.0,0),COLORFF00BB;
STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.8,0),COLORFF00D1;
STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.6,0),COLORFF00DB;
STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.4,0),COLORFF00EA;
STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.2,0),COLORFF00F3;
STICKLINE(MD<0 AND MD>=REF(MD,1),0,MD,0.1,0),COLORFF00FF;
STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,1.0,0),COLORFFA400;
STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.8,0),COLORFFB700;
STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.6,0),COLORFFC800;
STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.4,0),COLORFFDB00;
STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.2,0),COLORFFF000;
STICKLINE(MD<0 AND MD<REF(MD,1),0,MD,0.1,0),COLORFFFF00;
DIF:(EMA(CLOSE,12)-EMA(CLOSE,26))*100,colorlimagenta,LINETHICK1;
DEA:EMA(DIF,9),colorliblue,LINETHICK1;
MACD:2*(DI-DE),NODRAW;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),colorwhite,LINETHICK2;
DRAWICON(CROSS(J,K) AND CROSS(RSI1,RSI2) AND (CROSS(CCI,-100) OR CROSS(CCI,100)),0,9);
200,colorgreen,DOTLINE;
150,colorwhite,POINTDOT;
100,colorwhite,DOTLINE;
0,colorgray,LINETHICK2;
-100,colorwhite,DOTLINE;
-150,colorwhite,POINTDOT;
-200,colorgreen,DOTLINE;
DRAWICON(CROSS(J,K),K,1);
DRAWICON(CROSS(K,J),K,2);
DRAWICON(CROSS(RSI1,RSI2),RSI2,1);
DRAWICON(CROSS(RSI2,RSI1),RSI2,2);
DRAWICON(CROSS(CCI,-100) OR CROSS(CCI,100),CCI,1);
DRAWICON(CROSS(100,CCI),CCI,2);
DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,'顺势而为(KDJ+MACD+CCI+RSI)'),coloryellow;
您需要登录后才可以回帖 登录 | 立即注册




回顶部