请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 139|回复: 0

[同花顺] 同花顺底部建仓买卖指标公式(源码 副图 主图 贴图)

[复制链接]

6298

主题

12

听众

4万

积分

顶牛元老

Rank: 8Rank: 8

UID
507
好友
7
精华
1
顶牛币
18655
在线时间
383 小时
注册时间
2012-10-24
发表于 2018-2-14 08:49 |显示全部楼层
分享到:
ema1:=EMA(CLOSE,n1);
ema2:=EMA(CLOSE,n2),colorred;
ema3:=EMA(CLOSE,n3),colorcyan;
var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
var12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
var13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
var14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
var15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
var16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
买:=(var11+var13+var15+var17);
卖:=(var12+var14+var16+var18);
DRAWTEXT(买>0,LOW-0.1,'必进'),colorred,;
DRAWTEXT(卖>0,HIGH+0.1,'清仓'),colorgreen,;
//DRAWTEXT(CROSS(EMA1,EMA3),LOW-0.1,'X'),colorred,;
//DRAWTEXT(CROSS(EMA3,EMA1),HIGH+0.2,'X'),colorgreen,;
//DRAWTEXT(CROSS(EMA1,EMA2),LOW-0.1,'X'),colorred,;
//DRAWTEXT(CROSS(EMA2,EMA1),HIGH+0.2,'X'),colorgreen,;
//DRAWTEXT(CROSS(EMA2,EMA3),LOW-0.1,'X'),colorred,;
//DRAWTEXT(CROSS(EMA3,EMA2),HIGH+0.2,'X'),colorgreen,;
b:=TROUGHBARS(3,5,1)=0;
e:=PEAKBARS(3,5,1)=0;
DRAWICON(b,LOW-0.1,1),colorred;
DRAWICON(e,HIGH,2);
DRAWNUMBER(e,HIGH+(H*0.1),TOSTRING(H,2));//画数字
DRAWNUMBER(b,LOW*0.95,TOSTRING(LOW,2));//画数字
突破:REF(EMA(C,14),1),coloryellow;
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,0,0),COLOR000099;//柱线
STICKLINE(A1X<0,空方,突破,0,0),COLOR00CC66;//柱线
均价线:SUM(C*V,240)/SUM(V,240),colormagenta;
新价:CLOSE,colorwhite;
AA:=ZIG(3,5),coloryellow;
DIFF1 : =-(EMA(AA,26) - EMA(AA,12));
DEA1  : =-(EMA(DIFF1,9));
MACD1 : =2*(DIFF1-DEA1);
//转向变盘建仓
X:=IF(MACD1<0 AND REF(MACD1,2)>REF(MACD1,1) AND MACD1>REF(MACD1,1),1,0);
DRAWTEXT(X,LOW*0.9,"建仓"),coloryellow;
//量价指标
VPT:=SUM(VOL/EMA(VOL,N)*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1),0);
MAVPT:=EMA(VPT,M);
//DRAWTEXT(CROSS(VPT,MAVPT),新价+0.3,"B"),colorred;
//DRAWTEXT(CROSS(MAVPT,VPT),新价-0.3,"S"),colorgreen;
//均价线金叉
DRAWICON(CROSS(新价,均价线) AND 新价>突破 AND CLOSE>MA(CLOSE,144),均价线,1);
DRAWICON(CROSS(突破,均价线),均价线,1);
//底部
B:=ZIG(3,50/5),colorred;
G:=MA(B,2),coloryellow;
D:=CROSS(B,G)*(-0.5),STICK,colormagenta,LINETHICK3;//
DRAWTEXT(D<0,LOW*0.85,"底部"),coloryellow;
您需要登录后才可以回帖 登录 | 立即注册



回顶部