请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 124|回复: 0

[通达信] 通达信量价共振及低吸选股预警公式贴图源码

[复制链接]

6409

主题

8

听众

6万

积分

顶牛元老

Rank: 8Rank: 8

UID
6
好友
6
精华
1
顶牛币
26756
在线时间
385 小时
注册时间
2012-9-3

周荐股冠军

发表于 2018-3-7 10:02 |显示全部楼层
分享到:
STICKLINE(C,0,90,6,0),COLOR002500;
获利盘:WINNER(C)*100,COLORFF88FF,NODRAW;
趋势:3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),,COLORFFFFFF,NODRAW;
ZZ:=趋势>REF(趋势,1);
{资金动能}
DIFF:=EMA(C,3)-EMA(C,8);
DEA:=EMA(DIFF,5);
MACD:=2*(DIFF-DEA);
动能:=((EMA(C,3)-EMA(C,8)))*100;
CCI:="CCI";
K:="KD.K";
RSI:="RSI";
BIAS:="BIAS";
A1:=(CCI+250)/5;
A2:=K*1.15;
A3:=RSI*1.25;
A4:=BIAS*7.14;
A5:=(动能+100)*0.5;
趋势合成:(趋势+获利盘+A1+A2+A3+A4+A5)/7,COLOR00AAFF,NODRAW;
Z1:=SMA(趋势合成,10,1);
Z2:=SMA(Z1,3,1);
Z3:=SMA(趋势合成,5,3);
DRAWBAND(Z1,RGB(225,0,0),Z2,RGB(0,122,255));
DRAWBAND(趋势合成,RGB(225,111,0),Z3,RGB(0,122,0));
{量价异动}
K1:=DVOL/1000000;
K2:=DCLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06,;
量异动:=K1>REF(V1,1)*1.6&&ZZ,;
停牌:=DYNAINFO(17)>0;
M1:=SUM(价异动,2)>0 AND 停牌;
M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
量价共振:FILTER(M1&&M2,3)*66,COLOR9000FF;
8,COLOR777777;
减仓:IF(CROSS(Z3,趋势合成) AND REF(趋势合成,1)>=70,75,80),COLORFFBB00;
沽空:IF(CROSS(Z3,趋势合成) AND REF(趋势合成,1)>=78,77,85),COLOR00FF00;
低吸:IF(FILTER(CROSS(趋势合成,Z3) AND REF(趋势,1)<=12 AND RSI>REF(RSI,1),3),18,0),COLOR00FFFF;
{背离}
LC:=REF(C,1);
RSI1:=(SMA(MAX((C-LC),0),3,1)/SMA(ABS((C-LC)),3,1))*100;
顶背:=CROSS(88,RSI1);
DRAWTEXT(顶背,趋势合成*1.2,'←顶背'),COLORFFFFFF;
XG:低吸=18,COLOR00CCFF,NODRAW;
年选股:SUM(XG,250),NODRAW,COLORFFFFFF;
四日3%:HHV(H,3)>REF(C,3)*1.03 AND REF(CROSS(XG,0.8),2),NODRAW,COLOR0000FF;
年成功:SUM(四日3%,250),NODRAW;
成功率:(年成功/年选股)*100,NODRAW,COLOR0000FF;
达标:IF(四日3%=1,-1,DRAWNULL),CIRCLEDOT COLOR0077FF,LINETHICK3;

预警公式
{记住:未来函数,别当宝!}
趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
ZZ:=趋势>REF(趋势,1);
{量价异动}
K1:=DVOL/1000000;
K2:=DCLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06,;
量异动:=K1>REF(V1,1)*1.6&&ZZ;
停牌:=DYNAINFO(17)>0;
M1:=SUM(价异动,2)>0 AND 停牌;
M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
量价共振:FILTER(M1&&M2,3)*66;

=================

获利盘:=WINNER(C)*100;
趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
ZZ:=趋势>REF(趋势,1);
动能:=((EMA(C,3)-EMA(C,8)))*100;
CCI:="CCI";
K:="KD.K";
RSI:="RSI";
BIAS:="BIAS";
A1:=(CCI+250)/5;
A2:=K*1.15;
A3:=RSI*1.25;
A4:=BIAS*7.14;
A5:=(动能+100)*0.5;
趋势合成:=(趋势+获利盘+A1+A2+A3+A4+A5)/7;
Z3:=SMA(趋势合成,5,3);
低吸:FILTER(CROSS(趋势合成,Z3) AND REF(趋势,1)<=12 AND RSI>REF(RSI,1),3);


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

您需要登录后才可以回帖 登录 | 立即注册



回顶部