请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 229|回复: 1

[通达信] 通达信斐波那契周期角度线指标公式贴图源码

[复制链接]

7234

主题

10

听众

7万

积分

顶牛元老

Rank: 8Rank: 8

UID
6
好友
6
精华
1
顶牛币
27662
在线时间
429 小时
注册时间
2012-9-3

周荐股冠军

发表于 2018-3-16 09:11 |显示全部楼层
分享到:
HDAY:=800;LDAY:=800;调点:=3;角度:=100;之字幅度:=25;横向调节:=1;
TCH:=CONST(FINDHIGH(H,0,HDAY*10,1));
GTT:=CONST(BARSLAST(TCH=H))+1;
SX跌H:=CONST(IF(GTT=1,H,REF(H,GTT-1)));
BCL:=CONST(FINDLOW(L,0,LDAY*10,1));
DTT:=CONST(BARSLAST(BCL=L))+1;
SX涨L:=CONST(IF(DTT=1,L,REF(L,DTT-1)));
涨点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(L=SX涨L)+1));
跌点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(H=SX跌H)+1));
最低:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,涨点,跌点)));
L斜率:=角度/IF(C<300,1000,10);
最高:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,跌点,涨点)));
H斜率:=角度/IF(C<300,1000,10);
IM68:=((SX跌H-SX涨L)/6-(SX跌H-SX涨L)/8);
GH跌X:=SX跌H+(SX跌H-SX涨L)/8;
DL涨X:=SX涨L-(SX跌H-SX涨L)/8;
GTHT:=IF(DTT>GTT,DTT,GTT);
R:=ABS(GTT-DTT);
{DRAWTEXT(CURR=GTHT,SX涨L-IM68,'牛金画线'),COLOR8899AA;}
天线:=SX跌H;
地线:=SX涨L;
上斜线1:=IF(地线+CONST(L斜率*1.618)*最低>=地线,地线+CONST(L斜率*1.618)*最低,DRAWNULL);
上斜线2:=IF(地线+CONST(L斜率*1.000)*最低>=地线,地线+CONST(L斜率*1.000)*最低,DRAWNULL);
上斜线3:=IF(地线+CONST(L斜率*0.618)*最低>=地线,地线+CONST(L斜率*0.618)*最低,DRAWNULL);
上斜线4:=IF(地线+CONST(L斜率*0.382)*最低>=地线,地线+CONST(L斜率*0.382)*最低,DRAWNULL);
上斜线5:=IF(地线+CONST(L斜率*0.316)*最低>=地线,地线+CONST(L斜率*0.316)*最低,DRAWNULL);
上斜线6:=IF(地线+CONST(L斜率*0.250)*最低>=地线,地线+CONST(L斜率*0.250)*最低,DRAWNULL);
上斜线7:=IF(地线+CONST(L斜率*0.156)*最低>=地线,地线+CONST(L斜率*0.156)*最低,DRAWNULL);
上斜线8:=IF(地线+CONST(L斜率*0.092)*最低>=地线,地线+CONST(L斜率*0.092)*最低,DRAWNULL);
上斜线9:=IF(地线+CONST(L斜率*0.055)*最低>=地线,地线+CONST(L斜率*0.055)*最低,DRAWNULL);
上斜线10:=IF(地线+CONST(L斜率*0.025)*最低>=地线,地线+CONST(L斜率*0.025)*最低,DRAWNULL);
上斜线11:=IF(地线+CONST(L斜率*0.000)*最低>=地线,地线+CONST(L斜率*0.000)*最低,DRAWNULL);
上11:IF(上斜线11<=天线*1.05,上斜线11,DRAWNULL)COLORRED;
上10:IF(上斜线10<=天线*1.05,上斜线10,DRAWNULL)COLORRED;
上9:IF(上斜线9<=天线*1.05,上斜线9,DRAWNULL)COLORRED;
上8:IF(上斜线8<=天线*1.05,上斜线8,DRAWNULL)COLORRED;
上7:IF(上斜线7<=天线*1.05,上斜线7,DRAWNULL)COLORRED;
上6:IF(上斜线6<=天线*1.05,上斜线6,DRAWNULL)COLORYELLOW;
上5:IF(上斜线5<=天线*1.05,上斜线5,DRAWNULL)COLORRED;
上4:IF(上斜线4<=天线*1.05,上斜线4,DRAWNULL)COLORRED;
上3:IF(上斜线3<=天线*1.05,上斜线3,DRAWNULL)COLORRED;
上2:IF(上斜线2<=天线*1.05,上斜线2,DRAWNULL)COLORRED;
上1:IF(上斜线1<=天线*1.05,上斜线1,DRAWNULL)COLORRED;
下斜线1:=IF(天线-CONST(H斜率*1.618)*最高<=天线,天线-CONST(H斜率*1.618)*最高,DRAWNULL);
下斜线2:=IF(天线-CONST(H斜率*1.000)*最高<=天线,天线-CONST(H斜率*1.000)*最高,DRAWNULL);
下斜线3:=IF(天线-CONST(H斜率*0.618)*最高<=天线,天线-CONST(H斜率*0.618)*最高,DRAWNULL);
下斜线4:=IF(天线-CONST(H斜率*0.382)*最高<=天线,天线-CONST(H斜率*0.382)*最高,DRAWNULL);
下斜线5:=IF(天线-CONST(H斜率*0.316)*最高<=天线,天线-CONST(H斜率*0.316)*最高,DRAWNULL);
下斜线6:=IF(天线-CONST(H斜率*0.250)*最高<=天线,天线-CONST(H斜率*0.250)*最高,DRAWNULL);
下斜线7:=IF(天线-CONST(H斜率*0.156)*最高<=天线,天线-CONST(H斜率*0.156)*最高,DRAWNULL);
下斜线8:=IF(天线-CONST(H斜率*0.092)*最高<=天线,天线-CONST(H斜率*0.092)*最高,DRAWNULL);
下斜线9:=IF(天线-CONST(H斜率*0.055)*最高<=天线,天线-CONST(H斜率*0.055)*最高,DRAWNULL);
下斜线10:=IF(天线-CONST(H斜率*0.025)*最高<=天线,天线-CONST(H斜率*0.025)*最高,DRAWNULL);
下斜线11:=IF(天线-CONST(H斜率*0.000)*最高<=天线,天线-CONST(H斜率*0.000)*最高,DRAWNULL);
下11:IF(下斜线11>=地线*0.95,下斜线11,DRAWNULL),COLORGREEN;
下10:IF(下斜线10>=地线*0.95,下斜线10,DRAWNULL),COLORGREEN;
下9:IF(下斜线9>=地线*0.95,下斜线9,DRAWNULL),COLORGREEN;
下8:IF(下斜线8>=地线*0.95,下斜线8,DRAWNULL),COLORGREEN;
下7:IF(下斜线7>=地线*0.95,下斜线7,DRAWNULL),COLORGREEN;
下6:IF(下斜线6>=地线*0.95,下斜线6,DRAWNULL),COLORYELLOW;
下5:IF(下斜线5>=地线*0.95,下斜线5,DRAWNULL),COLORGREEN;
下4:IF(下斜线4>=地线*0.95,下斜线4,DRAWNULL),COLORGREEN;
下3:IF(下斜线3>=地线*0.95,下斜线3,DRAWNULL),COLORGREEN;
下2:IF(下斜线2>=地线*0.95,下斜线2,DRAWNULL),COLORGREEN;
下1:IF(下斜线1>=地线*0.95,下斜线1,DRAWNULL),COLORGREEN;
DRAWTEXT(上斜线11<=天线*1.05 AND CURRBARSCOUNT=30,上斜线11,'8X1'),COLOR00FF00;
DRAWTEXT(上斜线10<=天线*1.05 AND CURRBARSCOUNT=30,上斜线10,'4X1'),COLOR00FF00;
DRAWTEXT(上斜线9<=天线*1.05 AND CURRBARSCOUNT=30,上斜线9,'3X1'),COLOR00FF00;
DRAWTEXT(上斜线8<=天线*1.05 AND CURRBARSCOUNT=30,上斜线8,'2X1'),COLOR00FF00;
DRAWTEXT(上斜线7<=天线*1.05 AND CURRBARSCOUNT=30,上斜线7,'3X2'),COLOR00FF00;
DRAWTEXT(上斜线6<=天线*1.05 AND CURRBARSCOUNT=30,上斜线6,'1X1'),COLOR00FF00;
DRAWTEXT(上斜线5<=天线*1.05 AND CURRBARSCOUNT=30,上斜线5,'2X3'),COLOR00FF00;
DRAWTEXT(上斜线4<=天线*1.05 AND CURRBARSCOUNT=30,上斜线4,'1X2'),COLOR00FF00;
DRAWTEXT(上斜线3<=天线*1.05 AND CURRBARSCOUNT=30,上斜线3,'1X3'),COLOR00FF00;
DRAWTEXT(上斜线2<=天线*1.05 AND CURRBARSCOUNT=30,上斜线2,'1X4'),COLOR00FF00;
DRAWTEXT(上斜线1<=天线*1.05 AND CURRBARSCOUNT=30,上斜线1,'1X8'),COLOR00FF00;
DRAWTEXT(下斜线11>=地线*0.95 AND CURRBARSCOUNT=10,下斜线11,'8X1'),COLOR00FF00;
DRAWTEXT(下斜线10>=地线*0.95 AND CURRBARSCOUNT=10,下斜线10,'4X1'),COLOR00FF00;
DRAWTEXT(下斜线9>=地线*0.95 AND CURRBARSCOUNT=10,下斜线9,'3X1'),COLOR00FF00;
DRAWTEXT(下斜线8>=地线*0.95 AND CURRBARSCOUNT=10,下斜线8,'2X1'),COLOR00FF00;
DRAWTEXT(下斜线7>=地线*0.95 AND CURRBARSCOUNT=10,下斜线7,'3X2'),COLOR00FF00;
DRAWTEXT(下斜线6>=地线*0.95 AND CURRBARSCOUNT=10,下斜线6,'1X1'),COLOR00FF00;
DRAWTEXT(下斜线5>=地线*0.95 AND CURRBARSCOUNT=10,下斜线5,'2X3'),COLOR00FF00;
DRAWTEXT(下斜线4>=地线*0.95 AND CURRBARSCOUNT=10,下斜线4,'1X2'),COLOR00FF00;
DRAWTEXT(下斜线3>=地线*0.95 AND CURRBARSCOUNT=10,下斜线3,'1X3'),COLOR00FF00;
DRAWTEXT(下斜线2>=地线*0.95 AND CURRBARSCOUNT=10,下斜线2,'1X4'),COLOR00FF00;
DRAWTEXT(下斜线1>=地线*0.95 AND CURRBARSCOUNT=10,下斜线1,'1X8'),COLOR00FF00;



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

7234

主题

10

听众

7万

积分

顶牛元老

Rank: 8Rank: 8

UID
6
好友
6
精华
1
顶牛币
27662
在线时间
429 小时
注册时间
2012-9-3

周荐股冠军

发表于 2018-3-16 09:12 |显示全部楼层

{斐波那契周期}
DRAWTEXT(CURRBARSCOUNT=GTT,SX跌H*0.98,'斐波那契下跌周期'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GTT,SX跌H*0.99,'1'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-2,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-2,SX跌H*0.99,'3'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-4,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-4,SX跌H*0.99,'5'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-7,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-7,SX跌H*0.99,'8'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-12,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-12,SX跌H*0.99,'13'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-20,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-20,SX跌H*0.99,'21'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-33,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-33,SX跌H*0.99,'34 '),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-54,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-54,SX跌H*0.99,'55'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-88,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-88,SX跌H*0.99,'89'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-143,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-143,SX跌H*0.99,'144'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-232,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-232,SX跌H*0.99,'233'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-376,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-376,SX跌H*0.99,'377'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-609,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-609,SX跌H*0.99,'610'),COLOR00FF00;
STICKLINE(CURRBARSCOUNT=GTT-986,SX跌H,SX涨L,0,0),COLOR556600;
DRAWTEXT(CURRBARSCOUNT=GTT-986,SX跌H*0.99,'987'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=DTT,SX涨L*1.03,'斐波那契上升周期'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=DTT,SX涨L*1.01,'1'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-2,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-2,SX涨L*1.01,'3'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-4,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-4,SX涨L*1.01,'5'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-7,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-7,SX涨L*1.01,'8'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-12,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-12,SX涨L*1.01,'13'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-20,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-20,SX涨L*1.01.01,'21'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-33,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-33,SX涨L*1.01,'34'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-54,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-54,SX涨L*1.01,'55'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-88,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-88,SX涨L*1.01,'89'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-143,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-143,SX涨L*1.01,'144'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-232,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-232,SX涨L*1.01,'233'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-376,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-376,SX涨L*1.01,'377'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-609,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-609,SX涨L*1.01,'610'),COLOR0000FF;
STICKLINE(CURRBARSCOUNT=DTT-986,SX跌H,SX涨L,0,0),COLORAA00AA;
DRAWTEXT(CURRBARSCOUNT=DTT-986,SX涨L*1.01,'987'),COLOR0000FF;
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册



回顶部