请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

投放广告请联系QQ:286095538

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 115|回复: 1

[通达信] 通达信高量梯 量学看盘系统主图指标公式贴图源码

[复制链接]

6409

主题

8

听众

6万

积分

顶牛元老

Rank: 8Rank: 8

UID
6
好友
6
精华
1
顶牛币
26756
在线时间
385 小时
注册时间
2012-9-3

周荐股冠军

发表于 2018-3-19 08:31 |显示全部楼层
分享到:
{公式名称: 高量梯
公式描述: 量学看盘系统主图二
无参数
公式类型: 技术指标公式-其他类型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}
X_1:=CONST(HHV(REF(HIGH,1),240));
X_2:=CONST(LLV(REF(LOW,1),240));
X_3:=X_1-X_2;
X_4:=LOW-X_3*0.03;
X_5:=HIGH+X_3*0.03;
X_6:=CLOSE>500;
X_7:=MAX(CLOSE,OPEN);
X_8:=MIN(CLOSE,OPEN);
X_9:=0;
X_10:=1;
X_11:=IF(X_6,HIGH,X_7);
X_12:=IF(X_6,LOW,X_8);
X_13:=IF(CLOSE>OPEN,IF(X_10=0,LOW,X_12),IF(X_10=0,HIGH,X_11));
X_14:=2/1000;
X_15:=CURRBARSCOUNT;
X_16:=120;
X_17:=X_15<=X_16;
X_18:=LOW;
X_19:=IF(X_9=0,X_18,REF(X_9,X_9));
基准价:IF(X_17,CONST(X_19),DRAWNULL),DOTLINE,COLORRED;
X_20:=基准价;
X_21:=X_20*X_14;
X_22:=ABS(LOW-X_20)<=X_21;
X_23:=ABS(OPEN-X_20)<=X_21;
X_24:=ABS(CLOSE-X_20)<=X_21;
X_25:=ABS(HIGH-X_20)<=X_21;
X_26:=X_22 OR X_23 OR X_24 OR X_25 AND X_17 AND X_15!=1;
X_27:=COUNT(X_26,X_16);
精准点个数:IF(X_27>0,X_27+1,0),NODRAW,COLORRED;
X_28:=AMOUNT/VOL/100;
X_29:=CLOSE>OPEN AND REF(CLOSE,1)>X_28 AND CLOSE>X_28 AND CLOSE<300;
STICKLINE(X_29,OPEN,CLOSE,1,0),COLORLICYAN;
X_30:=OPEN>CLOSE AND CLOSE<X_28 AND X_28>REF(CLOSE,1);
STICKLINE(X_30,OPEN,CLOSE,1,0),COLORRED;
X_31:=VOL>REF(VOL,1)*0.95 AND VOL<REF(VOL,1)*1.05;
X_32:=WINNER(CLOSE)-WINNER(OPEN)>=0.2 AND X_31;
STICKLINE(X_32,OPEN,CLOSE,1,0),COLORBLUE;
X_33:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
X_34:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND X_33>=4.945;
X_35:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND X_33<=(-4.945);
涨停价:IF(X_34,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
跌停价:IF(X_35,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
X_36:=REF(CLOSE,1);
X_37:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
STICKLINE(X_37,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(X_37,OPEN,CLOSE,1,0),COLORMAGENTA;
X_38:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
STICKLINE(X_38,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(X_38,HIGH,LOW,0,1),COLORGREEN;
X_39:=HHV(VOL,10);
X_40:=BARSLAST(X_39=VOL);
当前高量顶价:DRAWLINE(X_40=0 AND X_40<=10,MIN(CLOSE,OPEN),REF(X_40=0,1),REF(MIN(CLOSE,OPEN),1),1),COLORMAGENTA;
当前高量底价价:DRAWLINE(X_40=0 AND X_40<=10,MAX(CLOSE,OPEN),REF(X_40=0,1),REF(MAX(CLOSE,OPEN),1),1),COLORBROWN;
X_41:=OPEN-(OPEN-CLOSE)/3;
X_42:=(OPEN+CLOSE)/2;
X_43:=OPEN-2*(OPEN-CLOSE)/3;
STICKLINE((OPEN+CLOSE)/2 AND CLOSE/REF(CLOSE,1)>=1.035 OR REF(CLOSE,1)/CLOSE>=1.035,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,3,0),COLORBLUE;
流通市值:FINANCE(40)/100000000,NODRAW;
MA5角度:ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLORRED;
循环年位置:(CLOSE-LLV(CLOSE,225))/(HHV(CLOSE,225)-LLV(CLOSE,225))*100,NODRAW,COLORGREEN;
X_44:=HHV(VOL,10);
X_45:=BARSLAST(X_44=VOL);
X_46:=CROSS(REF(MAX(CLOSE,OPEN),X_45),CLOSE);
STICKLINE(X_46,MAX(CLOSE,OPEN)*1.02,MIN(CLOSE,OPEN)*0.98,0,1),COLORRED;
STICKLINE(X_46,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,10,0),COLORRED;
DRAWICON(OPEN>REF(MAX(CLOSE,OPEN),1) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND CLOSE>MA(CLOSE,5),LOW*0.97,11);
X_47:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5);
X_48:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3) AND REFX(CLOSE,8)<REFX(CLOSE,4);
X_49:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6);
X_50:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3);
X_51:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7);
X_52:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2);
X_53:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8);
X_54:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1);
X_55:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9);
X_56:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE;
X_57:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10);
X_58:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1);
X_59:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11);
X_60:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2);
X_61:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12);
X_62:=REFX(CLOSE,1)<REF(CLOSE,3);
X_63:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12) AND REF(CLOSE,9)>REF(CLOSE,13);
X_64:=IF(PERIOD<4,LOW*(1-(PERIOD+1)/10*0.01),LOW*0.98);
X_65:=IF(PERIOD<4,HIGH*(1+(PERIOD+1)/10*0.01),HIGH*1.05);
X_66:=CURRBARSCOUNT-1;
DRAWNUMBER(X_47 AND (X_48 OR X_66=0 OR (X_66=1 AND X_62) OR (X_66=2 AND X_60) OR (X_66=3 AND X_58) OR (X_66=4 AND X_56) OR (X_66=5 AND X_54) OR (X_66=6 AND X_52) OR (X_66=7 AND X_50)),X_64,1),COLORMAGENTA;
DRAWNUMBER(X_49 AND (X_50 OR X_66=0 OR (X_66=1 AND X_62) OR (X_66=2 AND X_60) OR (X_66=3 AND X_58) OR (X_66=4 AND X_56) OR (X_66=5 AND X_54) OR (X_66=6 AND X_52)),X_64,2),COLORMAGENTA;
DRAWNUMBER(X_51 AND (X_52 OR X_66=0 OR (X_66=1 AND X_62) OR (X_66=2 AND X_60) OR (X_66=3 AND X_58) OR (X_66=4 AND X_56) OR (X_66=5 AND X_54)),X_64,3),COLORMAGENTA;
DRAWNUMBER(X_53 AND (X_54 OR X_66=0 OR (X_66=1 AND X_62) OR (X_66=2 AND X_60) OR (X_66=3 AND X_58) OR (X_66=4 AND X_56)),X_64,4),COLORMAGENTA;
DRAWNUMBER(X_55 AND (X_56 OR X_66=0 OR (X_66=1 AND X_62) OR (X_66=2 AND X_60) OR (X_66=3 AND X_58)),X_64,5),COLORMAGENTA;
DRAWNUMBER(X_57 AND (X_58 OR X_66=0 OR (X_66=1 AND X_62) OR (X_66=2 AND X_60)),X_64,6),COLORMAGENTA;
DRAWNUMBER(X_59 AND (X_60 OR X_66=0 OR (X_66=1 AND X_62)),X_64,7),COLORMAGENTA;
DRAWNUMBER(X_61 AND (X_62 OR X_66<1),X_64,8),COLORMAGENTA;
DRAWNUMBER(X_63,X_64,9),COLORGREEN;
X_67:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5);



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

6409

主题

8

听众

6万

积分

顶牛元老

Rank: 8Rank: 8

UID
6
好友
6
精华
1
顶牛币
26756
在线时间
385 小时
注册时间
2012-9-3

周荐股冠军

发表于 2018-3-19 08:31 |显示全部楼层

X_68:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3) AND REFX(CLOSE,8)>REFX(CLOSE,4);
X_69:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6);
X_70:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3);
X_71:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7);
X_72:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2);
X_73:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8);
X_74:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1);
X_75:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9);
X_76:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE;
X_77:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10);
X_78:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1);
X_79:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11);
X_80:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2);
X_81:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12);
X_82:=REFX(CLOSE,1)>REF(CLOSE,3);
X_83:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12) AND REF(CLOSE,9)<REF(CLOSE,13);
DRAWNUMBER(X_67 AND (X_68 OR X_66=0 OR (X_66=1 AND X_82) OR (X_66=2 AND X_80) OR (X_66=3 AND X_78) OR (X_66=4 AND X_76) OR (X_66=5 AND X_74) OR (X_66=6 AND X_72) OR (X_66=7 AND X_70)),X_65,1),COLORMAGENTA;
DRAWNUMBER(X_69 AND (X_70 OR X_66=0 OR (X_66=1 AND X_82) OR (X_66=2 AND X_80) OR (X_66=3 AND X_78) OR (X_66=4 AND X_76) OR (X_66=5 AND X_74) OR (X_66=6 AND X_72)),X_65,2),COLORMAGENTA;
DRAWNUMBER(X_71 AND (X_72 OR X_66=0 OR (X_66=1 AND X_82) OR (X_66=2 AND X_80) OR (X_66=3 AND X_78) OR (X_66=4 AND X_76) OR (X_66=5 AND X_74)),X_65,3),COLORMAGENTA;
DRAWNUMBER(X_73 AND (X_74 OR X_66=0 OR (X_66=1 AND X_82) OR (X_66=2 AND X_80) OR (X_66=3 AND X_78) OR (X_66=4 AND X_76)),X_65,4),COLORMAGENTA;
DRAWNUMBER(X_75 AND (X_76 OR X_66=0 OR (X_66=1 AND X_82) OR (X_66=2 AND X_80) OR (X_66=3 AND X_78)),X_65,5),COLORMAGENTA;
DRAWNUMBER(X_77 AND (X_78 OR X_66=0 OR (X_66=1 AND X_82) OR (X_66=2 AND X_80)),X_65,6),COLORMAGENTA;
DRAWNUMBER(X_79 AND (X_80 OR X_66=0 OR (X_66=1 AND X_82)),X_65,7),COLORMAGENTA;
DRAWNUMBER(X_81 AND (X_82 OR X_66<1),X_65,8),COLORMAGENTA;
DRAWNUMBER(X_83,X_65,9),COLORGREEN;
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册



回顶部