请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

顶牛网官方QQ交流群

股票配资1-10杠杆

公布一只涨停5%

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 327|回复: 0

[通达信] 通达信防套之强势区间指标公式(源码 副图 主图 贴图)

[复制链接]

2417

主题

9

听众

4万

积分

顶牛元老

Rank: 8Rank: 8

UID
52
好友
17
精华
2
顶牛币
14443
在线时间
87 小时
注册时间
2012-9-5

周荐股冠军

发表于 2018-4-14 07:26 |显示全部楼层
分享到:
{强势区间}
{防套之【强势区间}
M:=1;
VAR1:=FINANCE(30)>=REF(FINANCE(30),130);
VAR2:=VAR1;
VAR3:=IF(NAMELIKE(5),0,1);
VAR4:=IF(NAMELIKE(6),0,1);
VAR5:=DYNAINFO(17)>0;
VAR6:=9500;
VAR7:=EXIST((CLOSE/REF(CLOSE,1)-1)*100>5.6,60);
VAR8:=DYNAINFO(4)>0;
VAR9:=DYNAINFO(7)<150;
VAR10:=CAPITAL/5500000<10;
VAR11:=VAR7 AND VAR8 AND VAR9 AND VAR10 AND CLOSE<150 AND FINANCE(42)<VAR6 AND VAR3 AND VAR4;
VAR12:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
VAR13:=DYNAINFO(5)<0.01 OR DYNAINFO(6)<0.01;
VAR14:=IF(VAR13,1,VAR12<DYNAINFO(5)+0.01 AND VAR12>DYNAINFO(6)-0.01);
VAR15:=IF(VAR14,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120));
VAR16:=EVERY(VAR15>REF(VAR15,1),1);
VAR17:=IF(VAR16,VAR15,DRAWNULL);
VAR18:=STICKLINE(VAR17 AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,
-VOL)/100),0),30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),
0),30),1),1) AND IF(MA(WINNER(CLOSE*0.9)*100*CLOSE,3)>10,MA(WINNER(CLOSE*0.9)*100*CLOSE,3),
0)/2/8>0 AND VAR11,REFDATE(HHV(HIGH,(-5)),DATE),REFDATE(LLV(LOW,(-5)),DATE),4,0);
VAR19:=STICKLINE(EVERY(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)>REF(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)
,1),1) AND EVERY(MA(10000*CLOSE/INDEXC,10)>REF(MA(10000*CLOSE/INDEXC,10),1),1)
AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),
30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),30),1),1)
AND VAR11,REFDATE(HHV(HIGH,(-5)),DATE),REFDATE(LLV(LOW,(-5)),DATE),6,0);
VAR20:=STICKLINE(EVERY(XMA(XMA(LOW,25),25)-(XMA(XMA(HIGH,25),25)-XMA(XMA(LOW,25),
25))*1>REF(XMA(XMA(LOW,25),25)-(XMA(XMA(HIGH,25),25)-XMA(XMA(LOW,25),25))*1,1),1)
AND COST(EMA(SLOPE(CLOSE,15)*20+CLOSE,30))>=REF(COST(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)),1)
AND COST(20)>=REF(COST(20),1) AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),
VOL,-VOL)/100),0),30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),
0),30),1),1) AND VOL/MA(VOL,55)*100>50 AND EVERY(EMA(EMA(CLOSE,12)-EMA(CLOSE,26),
9)>REF(EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9),1),1) AND VAR11,REFDATE(HHV(HIGH,(-5)),DATE),
REFDATE(LLV(LOW,(-5)),DATE),4,0);
强势区:=STICKLINE(VAR11 AND EVERY(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)>REF(EMA(SLOPE(CLOSE,15)*20+CLOSE,30),
1),1) AND EVERY(MA(10000*CLOSE/INDEXC,10)>REF(MA(10000*CLOSE/INDEXC,10),1),1)
AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),
30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),30),1),1)
AND IF(MA(WINNER(CLOSE*0.9)*100*CLOSE,3)>10,MA(WINNER(CLOSE*0.9)*100*CLOSE,3),0)/2/8>0
AND VAR18 AND VAR19 AND VAR20 AND VAR11,REFDATE(HHV(HIGH,(-5)),DATE),REFDATE(LLV(LOW,(-5)),
DATE),4,0),COLOR001050;
STICKLINE(REF(NOT(强势区),1),0,10000,4,-1),COLORGREEN;
STICKLINE(强势区,0,10000,4,0),COLORRED;
每股总价值:IF(FINANCE(3),FINANCE(18)+FINANCE(32)+FINANCE(33)+FINANCE(34)+(FINANCE(13)+FINANCE(22)
+FINANCE(25))/FINANCE(1),DRAWNULL),COLORGREEN,NODRAW;
静值:IF(FINANCE(3),FINANCE(18)+FINANCE(32)+FINANCE(33)+FINANCE(34){+FINANCE(38)},DRAWNULL),COLORYELLOW,NODRAW;
应收款:IF(FINANCE(3),FINANCE(22)/FINANCE(1),DRAWNULL),COLORWHITE,NODRAW;
现金流:IF(FINANCE(3),FINANCE(25)/FINANCE(1),DRAWNULL),COLORMAGENTA,NODRAW;
无形资:IF(FINANCE(3),FINANCE(13)/FINANCE(1),DRAWNULL),COLORWHITE,NODRAW;

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

您需要登录后才可以回帖 登录 | 立即注册



回顶部