请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

顶牛网官方QQ交流群

股票配资1-10杠杆

公布一只涨停5%

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 96|回复: 0

[通达信] 通达信量化交易多空概率系统指标公式

[复制链接]

4621

主题

7

听众

5万

积分

顶牛元老

Rank: 8Rank: 8

UID
40
好友
4
精华
0
顶牛币
18554
在线时间
237 小时
注册时间
2012-9-5
发表于 2018-5-10 10:02 |显示全部楼层
分享到:
n 1 100 4 m 1 100 4
NK:=O#YEAR;NS:=C#YEAR;
STICKLINE(NS>=NK,NS,NK,8,0),COLOR000099;
STICKLINE(NS<NK,NS,NK,8,0),COLORLICYAN;
QQ1:=VOL/((DHIGH-DLOW)*2-ABS(DCLOSE-DOPEN));   
主买:=IF(DCLOSE>DOPEN,QQ1*(DHIGH-DLOW),IF(DCLOSE<DOPEN,QQ1*((DHIGH-DOPEN)+(DCLOSE-DLOW)),VOL/2));   
主卖:=IF(DCLOSE>DOPEN,0-QQ1*((DHIGH-DCLOSE)+(DOPEN-DLOW)),IF(DCLOSE<DOPEN,0-QQ1*(DHIGH-DLOW),0-VOL/2));   
DD:=(主买+主卖)/10000;   
DDX1:=EMA(DD,60)*60;   
DDX2:=MA(DDX1,N);   
DDX3:=MA(DDX1,M);
      STICKLINE(DDX1<DDX3,H,L,0,0),COLORGREEN;
      STICKLINE(DDX1<DDX3,C,O,4,0),COLOR00B500;
      STICKLINE(DDX1<DDX3,C,O,3,0),COLOR00C600;
      STICKLINE(DDX1<DDX3,C,O,2,0),COLOR00D500;
      STICKLINE(DDX1<DDX3,C,O,1,0),COLOR00E600;
      STICKLINE(DDX1>DDX3,H,L,0,0),COLOR106FFF;
      STICKLINE(DDX1>DDX3,C,O,4,0),COLOR0000C8;
      STICKLINE(DDX1>DDX3,C,O,3,0),COLOR0000D7;
      STICKLINE(DDX1>DDX3,C,O,2,0),COLOR0000EA;
      STICKLINE(DDX1>DDX3,C,O,1,0),COLOR0000FF;
      STICKLINE(DDX1<DDX2 AND DDX1>DDX3,H,L,0,0),COLORFF5D10;
      STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,4,0),COLORFF5D10;
      STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,3,0),COLORFF7710;
      STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2,0),COLORFF9910;
      STICKLINE(DDX1>DDX2 AND DDX1<DDX3,H,L,0,0),COLORFF00FF;
      STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,4,0),COLORD000D0;
      STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,3,0),COLORE600E6;
      STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2,0),COLORF900F9;
      STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,1,0),COLORFF09FF;
JRH:=HHV(CLOSE,2);
JRL:=LLV(CLOSE,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); {GUPIAOFF.COM}
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:=VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:离场,COLORFF99FF,NODRAW;
今离场价:REF(离场,1)COLOR0000FF,NODRAW;
青色观望:=VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:进,COLOR33AACC,NODRAW;
今进场价:REF(明进场价,1),COLOR00FF00,NODRAW;
短买:=VAR19,COLOR33AACC,NODRAW;
品红离场:=VAR1A,COLORFF99FF,NODRAW;
急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
CO:=(C-O);
STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;
STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;
ZC:=DCLOSE#WEEK;
ZO:=DOPEN#WEEK;
ZH:=DHIGH#WEEK;
ZL:=DLOW#WEEK;
ZJ:=(ZC+ZO+ZH+ZL)/4;
做空68:ZJ*(1+0.068),COLORRED;
做空95:ZJ*(1+0.136),COLORBLUE;
做多68:ZJ*(1-0.068),COLORGREEN;
做多95:ZJ*(1-0.136),COLOR8409FF;


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

您需要登录后才可以回帖 登录 | 立即注册



回顶部