请选择 进入手机版 | 继续访问电脑版

顶牛论坛

 找回密码
 立即注册
搜索

顶牛网官方QQ交流群

股票配资1-10杠杆

公布一只涨停5%

量价招式擒获飞天妖股

强势黑马起爆点指标主力吸筹完毕启动四色柱很牛的副图指标黄金柱  好用的成交量指标
机构买入看盘牛股启动指标公式百万股神擒牛指标公式短线底部抄底和高位逃顶指标
绝密量能买点主力暴力拉升指标公式洞察主力游资大户散户资金王子操盘线指标公式
集合竞价抓板指标公式通达信龙虎榜通达信主力控盘系数通达信六区DK指标
抓起爆点超精准选股公式通达信控盘程度选股公式源码RSI突破下降趋势线股票活跃度指标公式
查看: 61|回复: 0

[通达信] 通达信平安量成交量副图指标公式贴图源码

[复制链接]

5674

主题

8

听众

6万

积分

顶牛元老

Rank: 8Rank: 8

UID
39
好友
5
精华
0
顶牛币
30734
在线时间
313 小时
注册时间
2012-9-5
发表于 2018-5-17 17:00 |显示全部楼层
分享到:
DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'H3',0);
M1:=5; M2:=10;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
虚拟量:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
成交量:VOL,NODRAW;
五日均量:MA(成交量,M1);
十日均量:MA(成交量,M2);
大单动向:(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7),COLORRED,NODRAW;
LC:=REF(CLOSE,1);
RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃度:(RSI5-WR10),COLORFFFF00,LINETHICK1,NODRAW;
{--------VOL.量能饱和--------}
N1:=34;
N2:=N1*1.05;
N3:=N1+3;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:IF(SAT>1,1,SAT)*100,COLOR0099FF,NODRAW;
中点:=REF(REFDATE(HHV(V,60)/2,DATE),5);{量能饱和的变色切换}
{中点:=REFDATE(HHV(V,240)/2,DATE);}
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),虚拟量,0,-1,-1),COLOR00C0C0;
STICKLINE("MACD.MACD">0,0,V,2.8,1),COLORRED;
STICKLINE("MACD.MACD"<=0,0,V,2.8,1),COLORCYAN;
VAR2:=CLOSE-REF(CLOSE,1);
VAR3:=IF(CLOSE-REF(CLOSE,1)>=0,VAR2,0);
VAR4:=REF(CLOSE,1)-CLOSE;
VAR5:=IF(CLOSE-REF(CLOSE,1)<=0,VAR4,0);
VAR6:=SUM(VAR3,16)/SUM(VAR5,16);
VAR7:=100-100/(1+VAR6);
VAR8:=EMA(VAR7,16);
VAR9:=EMA(VAR8,8);
VARA:=EMA(VAR8,45);
MO:=(VAR8-VARA);
ML:=(VAR9-VARA);
VAR1A:=EMA(CLOSE,32);
VAR2A:=MA(OPEN,32);
趋势:=(VAR1A-VAR2A);
STICKLINE(MO>ML AND 趋势<0 AND MO>REF(MO,3) AND 趋势>REF(趋势,3),VOL,0,2.5,0) COLORYELLOW;
C1:=10000*CLOSE/INDEXC;
O1:=10000*OPEN/INDEXO;
H1:=10000*HIGH/INDEXH;
L1:=10000*LOW/INDEXL;
STICKLINE((C>O AND C1>O1) OR ((C<O OR C>REF(C,1)) AND (C1>O1)),0,VOL/3*2,2.5,0),COLOR000099;
STICKLINE((C>O AND C1>O1) OR ((C<O OR C>REF(C,1)) AND (C1>O1)),0,VOL/3*2,1.3,0),COLOR0000CC;
STICKLINE((C>O AND C1>O1) OR ((C<O OR C>REF(C,1)) AND (C1>O1)),0,VOL/3*2,0.1,0),COLOR9966FF;
STICKLINE((C<O AND C1<O1) OR ((C>O OR C<REF(C,1)) AND (C1<O1)),0,VOL/3*2,2.5,0),COLORFF6600;
STICKLINE((C<O AND C1<O1) OR ((C>O OR C<REF(C,1)) AND (C1<O1)),0,VOL/3*2,1.3,0),COLORFF9933;
STICKLINE((C<O AND C1<O1) OR ((C>O OR C<REF(C,1)) AND (C1<O1)),0,VOL/3*2,0.1,0),COLORFFCC66;
STICKLINE(活跃度>0,0,VOL/3,2.5,0),COLOR990099;
STICKLINE(活跃度>0,0,VOL/3,1.3,0),COLORCC00CC;
STICKLINE(活跃度>0,0,VOL/3,0.1,0),COLORFF66FF;
STICKLINE(活跃度<0,0,VOL/3,2.5,0),COLOR009900;
STICKLINE(活跃度<0,0,VOL/3,1.3,0),COLOR00CC33;
STICKLINE(活跃度<0,0,VOL/3,0.1,0),COLOR99FF66;
大单动向限制:=IF(大单动向>1,1,IF(大单动向<-1,-1,大单动向));
流入:=IF(大单动向限制>0,大单动向限制,DRAWNULL);
流出:=IF(大单动向限制<=0,大单动向限制*-1,DRAWNULL);
STICKLINE(大单动向限制>0,0,VOL*流入,1,0),COLOR66CCFF;
STICKLINE(大单动向限制<0,0,VOL*流出,1,0),COLORFF0000;
{--------VOL.量能饱和--------}
STICKLINE(CURRBARSCOUNT=N1,中点*1.8,中点*1.6,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,中点*1.79,中点*1.61,量能饱和度,0),COLOR0055FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能饱和度,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.73,中点*1.67,量能饱和度,0),COLOR0099FF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能饱和度,0),COLOR00DDFF;
DRAWTEXT(CURRBARSCOUNT=N3,中点*1.7,'量能饱和度'),COLORYELLOW;


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

您需要登录后才可以回帖 登录 | 立即注册



回顶部